Filter löschen
Filter löschen

Matlab 2020b won't open on Mac OS Big Sur

54 Ansichten (letzte 30 Tage)
Laura Hobbs
Laura Hobbs am 16 Nov. 2020
Kommentiert: Eliza Lovrich am 23 Feb. 2023
I've recently updated to Matlab 2020b, which has worked fine for a number of weeks. I have updated my Mac OS to Big Sur this weekend, and Matlab 2020b now won't open (not excluding the possiblity that this could be a coincidence).
The icon appears for a second or so, as if it is loading up, and then disappears. I have tried restarting my computer, reinstalling Matlab, and reinstalling Java (following suggesitons on previous posts). Any recommnedations would be very welcome!
Thank you.

Akzeptierte Antwort

Ameer Hamza
Ameer Hamza am 16 Nov. 2020
See what happen when you try to start it from command line. Run following line in terminal
/Applications/MATLAB_R2020b.app/bin/matlab
  2 Kommentare
Laura Hobbs
Laura Hobbs am 16 Nov. 2020
This worked, thanks very much! Couldn't run through Terminal, but found the same file in the directory and it worked.
Is there any way I can now launch Matlab without having to follow this process everytime.
Thank you for your advice.
Ameer Hamza
Ameer Hamza am 16 Nov. 2020
I recently updated to Big Sur but didn't face this problem. So I am not able to try anything to solve this. Maybe create a symlink on the desktop so you can launch MATLAB by double-clicking it. For example
ln -s /Applications/MATLAB_R2020b.app/bin/matlab ~/Desktop/matlab

Melden Sie sich an, um zu kommentieren.

Weitere Antworten (6)

Dmitry Savransky
Dmitry Savransky am 22 Dez. 2020
I just ran into this, and it appears to be a disk access issue (same thing - can't launch from icon but can launch from command line). To fix, go to Preferences>Security & Privacy>Full Disk Acccess, unlock, and click the check box by MATLAB, and it should start launching via the dock icon once more.
  13 Kommentare
Emily Pitts
Emily Pitts am 24 Mai 2022
This also worked when using MATLAB 2022a on Monterey! Thanks!
Eliza Lovrich
Eliza Lovrich am 23 Feb. 2023
You are a lifesaver! Thanks!

Melden Sie sich an, um zu kommentieren.


Alperen kilic
Alperen kilic am 14 Dez. 2020
ı am using big sur on 2019 mac pro base model. when i click matlab, the pc is not responding.

John D'Errico
John D'Errico am 2 Jan. 2021
Bearbeitet: John D'Errico am 2 Jan. 2021
The simple solution of course to resolve any problems is to use R2021. It seems to run nicely on Big Sur. That is, given we are in 2021.
  1 Kommentar
Nanny Wermuth
Nanny Wermuth am 23 Jan. 2021
I cannot see any version 2021 on mathworks.com, so how did you access it?

Melden Sie sich an, um zu kommentieren.


thomas greenhill
thomas greenhill am 3 Feb. 2021
I'm also having this problem.
When I originally updated to Big Sur, I was able to get R2021a to open by changing the Full Disk Access settings as Dmitry suggested.
Big Sur automatically updated again last night, and I'm now on version 11.2, and MATLAB won't open this morning. The logo pops up and stays open, but the IDE never presents itself. The disk privileges fix that worked last time doesn't work anymore. I can't even open R2021a from the command line with sudo privileges by typing:
sudo "/Applications/MATLAB_R2021a.app/bin/matlab"
in terminal.
Is there a permanent fix for this? I've honeslty found Big Sur extremely buggy. Have others had a similar experience with the updated OS?
  2 Kommentare
Arun Tangirala
Arun Tangirala am 15 Feb. 2021
Yes, Big Sur better be renamed as Bug Sure, for the significantly poor and buggy performance!
With MATLAB and SIMULINK on Big Sur, I find slow response from SIMULINK. Add to it the screen sharing on MS Teams (sufficient to embarass you if you are a course instructor). Whether it is the issue with Big Sur or SIMULINK or their interplay, I am not sure but I suspect Big Sur has a stronger role in slowing things down. On the other hand, MATLAB, especially SIMULINK has also been growing into a resource consuming dinosaur :-)
Arun Tangirala
Arun Tangirala am 15 Feb. 2021
Btw, I am using updated Big Sur (Mac OS 11.1) and MATLAB R2020b.

Melden Sie sich an, um zu kommentieren.


thomas greenhill
thomas greenhill am 12 Feb. 2021
Update:
If you are connected to an external monitor, try unplugging it, opening up MATLAB with your laptop screen open, then plugging monitor back in.
This solved it for me and it appears MATLAB is still struggling with some screen-level events on macOS.
I hope this will help someone in the future!
  5 Kommentare
Catherine Davey
Catherine Davey am 1 Mär. 2022
This weird solution was a lifesaver for me!
Jacob Sibi
Jacob Sibi am 11 Apr. 2022
Bearbeitet: Jacob Sibi am 11 Apr. 2022
This solution is what worked for me! Thank you so much

Melden Sie sich an, um zu kommentieren.


Brentian~
Brentian~ am 6 Apr. 2022
Bearbeitet: Brentian~ am 6 Apr. 2022
I found this problem relates to the ATS.Framework on Mac OS. I was unable open matlab on Monterey using the -desktop option.
I fix this by following this thread.
https://discussions.apple.com/thread/251155390
Hope this helps someone for it bothers me for quite a long time

Kategorien

Mehr zu Introduction to Installation and Licensing finden Sie in Help Center und File Exchange

Produkte


Version

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by