MATLAB Answers

4

Why is MATLAB Help browser showing unformatted text on Linux (R2018b)

Asked by Richard Stephens on 10 Oct 2018
Latest activity Commented on by okultekin on 15 Sep 2019
In R2018b, when I bring up the Help browser, e.g. using
doc classdef
it brings up a window, but it's just unformatted text, and no graphics.
I'm on Ubuntu 18.04. It is fine on R2018a.

  4 Comments

Show 1 older comment
Did you ask the technical support team of MathWorks already?

Sign in to comment.

Products

5 Answers

Answer by Ken Morrison on 13 Nov 2018
Edited by Ken Morrison on 13 Nov 2018
 Accepted Answer

I was able to fix this problem on Ubuntu 18.04 LTS and Matlab R2018b. The following command, run from the system terminal, showed that the system was missing libgconf-2-4.
ldd ~/.matlab/R2018b/HtmlPanel/glnxa64/chromium/jxbrowser-chromium | grep -i found
Output shows missing shared library.
libgconf-2.so.4 => not found
Solution: Install libgconf-2-4 AND restart Matlab
sudo apt install libgconf-2-4
Thanks to Alexander Maye for pointing me at jxbrowser-chromium.

  6 Comments

thanks. Problem solved in ubuntu 18.04.2
Thank you. It's works for me (ubuntu 18.04 LTS)
Thanks a lot. It's works for me on UBUNTU 18.04 LTS too

Sign in to comment.


Answer by Alexander Maye on 7 Nov 2018
Edited by Alexander Maye on 7 Nov 2018

Just had a conversion with Mathwork's support, and this helped me to solve the problem in openSUSE Leap 15 in the following way:
1) make ~/.matlab/R2018b/HtmlPanel/glnxa64/chromium/jxbrowser-chromium executable
2) install libcrypto.so.1.0.0
On openSUSE, this library is provided by the package openssl1_0_0, and after installation, the help browser runs fine.

  2 Comments

Thanks for taking the trouble to answer, unfortunately, these commands did not work on my system (Ubuntu 18.04).
1) This command returned:
make: Nothing to be done for 'jxbrowser-chromium'.
make: *** No rule to make target 'executable'. Stop.
2) On Ubuntu I used:
sudo apt-get install libssl1.0.0
which successfully installed the library, but it made no difference to the help browser in Matlab.
Sorry for the confusion. To make something executable, enter chmod +x something.

Sign in to comment.


Answer by Bernard Llanos on 20 Nov 2018

I had the same symptoms on Ubuntu 18.04 (as well as the error described here), with R2018b, but for a slightly different problem:
ldd $MATLAB_INSTALLATION_FOLDER/R2018b/sys/jxbrowser-chromium/glnxa64/chromium/jxbrowser-chromium | grep -i found
The output shows that I had a broken link:
libgcrypt.so.11 => not found
since
$MATLAB_INSTALLATION_FOLDER/R2018b/sys/jxbrowser-chromium/glnxa64/chromium/libgcrypt.so.11
was a symbolic link to
/lib/x86_64-linux-gnu/libgcrypt.so.20.0.5
whereas I had
/lib/x86_64-linux-gnu/libgcrypt.so.20.2.1
I replaced the symbolic link with a link to the generic link
/lib/x86_64-linux-gnu/libgcrypt.so.20
which resolved the issues.

  3 Comments

Thank you. I cannot find a folder called chromium in glnxa64. I have only two folders lib and xulrunner.
Is something missing from mine?
I find that, I have libgcrypt.so.20.2.1 installed .Can you please tell how to replace the symbolic link with a generic link.
You are probably looking in
.../sys/jxbrowser/glnxa64
instead of
.../sys/jxbrowser-chromium/glnxa64
By generic link, I meant a symbolic link to a file that does not specify the version number so precisely (20 instead of 20.2.1 or 20.0.5)
If you run
ls -l /lib/x86_64-linux-gnu/libgcrypt.so.20*
you should see that there are two items listed, one which is libgcrypt.so.20, and which is actually a symbolic link to the other, which is a file called libgcrypt.so.20.2.1. If you create a symbolic link to libgcrypt.so.20, the link will be valid even when libgcrypt.so.20.2.1 is replaced with a newer version, because libgcrypt.so.20 will have been updated to point to the newer version.
Iam getting same problem on Windows after the update but I can't search anything in the help window and online documentation is also not working.

Sign in to comment.


Answer by Alexander Krings on 29 Mar 2019

I was able to solve this problem for R2019a on a CENTOS7 (64bit/only) system.
In the first step i located the jxbrowser-chromium (MATLAB/R2019a/sys/jxbrowser-chromium/glnxa64/chromium)
I opened a terminal and entered>
ldd jxbrowser-chromium | grep -i found
which gave me
libcrypto.so.1.0.0 => not found
Luckily I had the idea to search if the file was already on my system. I do not want to risk downloading a library that does cryptography "obviously" .. somewhere on the internet.
find . | grep so.1.0.0
showed me
./bin/glnxa64/libcrypto.so.1.0.0
./bin/glnxa64/libssl.so.1.0.0
that the missing file came already with the installation. I copied the file and send it to
MATLAB/R2019a/sys/jxbrowser-chromium/glnxa64/chromium
and also set
webutils.htmlrenderer('chromium');
in Matlab Command Window. Restart Matlab and it works. But, loading the pages is still pretty slow. This could be improved !

  0 Comments

Sign in to comment.


Answer by yunhui zhou on 23 Jun 2019

Same problem for Matlab R2018b on Kubuntu 19.04. In my case, running:
ldd ~/.matlab/R2018b/HtmlPanel/glnxa64/chromium/jxbrowser-chromium | grep -i found
showed that I was missing libgconf-2.so.4 and ibcrypto.so.1.0.0. I solved the problem by running:
sudo apt install libgconf-2-4
cp /usr/local/MATLAB/R2018b/bin/glnxa64/libcrypto.so.1.0.0 ~/.matlab/R2018b/HtmlPanel/glnxa64/chromium/
However, even after this rendering in the help broswer was slow, though it can correctly format the page.

  0 Comments

Sign in to comment.