MATLAB Answers

paste is disabled in the app designer

110 views (last 30 days)
Scott
Scott on 23 Feb 2017
Commented: Daniel Dieterle on 2 Sep 2020 at 7:41
Does anybody else find that "Paste" (as in clipboard copy and paste) is disabled when editing code in the "App Designer". I have no issues at all with pasting with the regular Matlab editor; only when using the App Designer. If I use Ctrl-V, nothing happens and if I right click with the mouse, "Paste" is greyed out.
I did some searching and see where some have had this issue with the regular editor 3 or 4 years ago and their solution was to reboot. I've tried that with no luck. Windows 7, 64 Bit. Matlab 2016B Thanks in advance! S

  4 Comments

Show 1 older comment
Purnendu Nath
Purnendu Nath on 12 Dec 2017
Sudarshan... Even in the editable section, for some reason Paste does not work, do you know how to get around that? it almost seems like there is Preference setting to disable Paste!
Michal Dobai
Michal Dobai on 13 Dec 2017
Hmm.. That sounds odd. Even if you create new project? Or it's a project-related thing? I've been working with app designer quite a lot lately and I have to say I noticed some strange, unexpected behavior several times. Not this particular one, though. But for me restart always worked just fine.
KJ N
KJ N on 20 May 2018
I am getting the same error (not being able to Paste). I can right click or Ctrl-C to copy from within a script or from the folder path and then paste into another program (website, Word, etc.) but I cannot paste into the Script Editor with either Ctrl-V or by right-clicking. I can edit the script contents as well as "click and drag" sections of text. Restarting the program fixed the issue, but it does appear to be a random bug. (2018a on Windows 10.)

Sign in to comment.

Answers (3)

Aravind C G
Aravind C G on 11 Mar 2019
Edited: Aravind C G on 22 Apr 2020
The fix that worked for me:
1) Return to design view. Copy paste a random element. Delete it.
2) Go back to code view. Try copy pasting. It should work.
EDIT: This bug happened to me once again, don't know the cause. But the above fix no longer worked. (March 23,2019)
Things that didn't work:
Just closing and reopening the same file in app designer
Restarting App Designer only (not restarting matlab) and then opening up the file again.
Possible Cause:
I think there is some issue with how App Designer switches between the two clipboards (that Melissa mentions below) when you change views. Will update this answer if I find the steps to reproduce the issue.

  0 Comments

Sign in to comment.


Melissa Williams
Melissa Williams on 25 Jan 2018
Hi Scott,
App Designer has two different clipboards, one for actions completed in the design area and one for text edits. If you are finding the paste buttons disabled when you want to paste in the text editor, try using the keyboard shortcut ctrl+v. However, this shouldn't be necessary because the paste buttons are for the editor in code view and the design area in design view. Please let me know if this issue persists and if so, what version of MATLAB you are using.
-Melissa

  10 Comments

Show 7 older comments
David Mitchell
David Mitchell on 10 Jan 2019
This is happening to me too, cannot paste into the main section
Raúl Díaz
Raúl Díaz on 2 Sep 2019
Still happening... nothing from above works (MATLAB 2018a & Windows 10)
Daniel Dieterle
Daniel Dieterle on 2 Sep 2020 at 7:41
Same Problem Win10, Matlabversion 2019b,

Sign in to comment.


Melissa Williams
Melissa Williams on 10 Jan 2019
Hi everyone,
If you are experiencing issues pasting, could you contact MATLAB tech support and let us know what OS and version of MATLAB and also if this is in the regular editor, editing a Live Script or in App Designer. Also if it's all the time or only after certain actions. Those details will help us narrow down why this happens sometimes and help offer suggestions.

  8 Comments

Show 5 older comments
Arturo Pino
Arturo Pino on 3 Mar 2020
I have the same issue here, March 2020 using Windows 10. Extremely irritating. I never realized how much of my workflow depends on copy/paste, but it's really slowing me down. Has Mathworks found a solution for this problem yet??
Mike King
Mike King on 23 Apr 2020
Mine works for a period then stops working using mouse or hotkeys, restart of the App Designer interface fixes it.
Amir Rahimi
Amir Rahimi on 6 Aug 2020
I have the same problem. it usually happens after calling matlab from Python and running my model.
then copy/paste will never work unless I restart the Windows.
It is really frustrating. Did you manage to find the solution?

Sign in to comment.

Categories

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by