Why I get error when I try deploying the blink LED example?

3 views (last 30 days)
Alpar Pali-Kis
Alpar Pali-Kis on 23 May 2021
I got the following error when I try to deploy the model onto the hardware (Launchxl-F28069M):
The following error occurred during deployment to your hardware board:
Debug Server Scripting (DSS) error: The system cannot find the path specified.
I am using CCS 10.2

Answers (1)

Shiva Kalyan Diwakaruni
Shiva Kalyan Diwakaruni on 26 May 2021
Hi,
First, make sure you correctly set up the C2000 Support Package by clicking the "setup" icon in the add-ons manager. This will take you through a series of steps to configure and locate installed TI products. This issue is most likely a result of MATLAB not being able to find a TI product such as TI C2000WARE. See the following link for short instructions on setting up the support package:
Make sure the board is set up correctly in the Hardware Implementation tab of the model's Configuration Parameters. Make sure Code Composer Studio is correctly set up and configured for Embedded Coder.
If these steps do not resolve the issue, you can programmatically build and download the model:
>> open('ModelName.slx');
>> rtwbuild('ModelName')
>> command = 'C:\ti\ccsv7\ccs_base\scripting\examples\loadti\loadti -a -c=f28379D.ccxml ModelName.out';
>> [status1,cmdout1] = system(command);
Make sure to replace the model name and the path to loadti with the appropriate values. However, this will prevent running in external mode and communicating with Simulink, so it is best to fully investigate the previous options before using this workaround.
Hope it helps.
  2 Comments

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by