Algebraic Loop Error in simulink

6 views (last 30 days)
I'm trying to simulate a field-oriented controlled induction motor fed from an SVPWM inverter and DC Source. Please help me with this error in magnitude-angle to complex block from simulink math operations library.
I tried to reduce the relative tolerance parameter from 1e-4 to a lower value, and I also tried using a trust region-based algorithm for the algebraic loop solver. Neither of the approaches worked.

Accepted Answer

Shiva Kalyan Diwakaruni
Shiva Kalyan Diwakaruni on 4 May 2021
Hi,
The above error is occuring during algebraic loops which occur when an input port with direct feedthrough is driven by the output of the same block, either directly, or by a feedback path through other blocks which have direct feedthrough.
Algebraic loops are discussed in the Simulink User's Guide, available at the following URL:
For suggestions on how to resolve a continuous algebraic loop, please refer to the following post:
Hope it helps.
  1 Comment
Sivakumar S
Sivakumar S on 8 May 2021
Thanks a lot for the response. I have solved my error.

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by