matlab new or old version perfectly work on win10 PC, but on a virtual machine window 10 cannot plot symbol, figure is empty; but if first plot line, then add symbol, it will work. Thanks for help

2 views (last 30 days)
Mingliang Zhang
Mingliang Zhang on 25 Oct 2019
Commented: Mingliang Zhang on 26 Oct 2019
matlab, old or new version, works perfectly on mac or win 10 PC,
but on a win10 virtual machine (after May 2019), I cannot plot symbol
if I use
clear all; clc;
x=[1,2,3,4,5];
y=x.^2;
figure(1),plot(x,y,'*');
I get a empty figure
but if I use
clear all; clc;
x=[1,2,3,4,5];
y=x.^2;
figure(1),plot(x,y);hold on
figure(1),plot(x,y,'*');
I can get both line with symbol on it
It must be caused by parallel Desktop and/or newer win10 update, help is highly appreciated

Answers (1)

Nadir Altinbas
Nadir Altinbas on 26 Oct 2019
try for below
plot x,y,r *
  1 Comment
Mingliang Zhang
Mingliang Zhang on 26 Oct 2019
Nadir: Thanks for response and your precous time
I tried
figure(1),plot(x,y,'r *')
it still gives me me empty figure
if I directly use in m file or command window:
plot x,y,r *
error message is
Error using plot
Invalid first data argument.
I can plot symbol previously in win 10 virtual machine (before May 2019), but find empty figure around August or September (must relate to some updates of win10). Now I have to use Matlab in Mac side, it is some sort of not convenient.
greetings!

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by