Not responding on startup, macOS Mojave

260 Ansichten (letzte 30 Tage)
William Smith
William Smith am 17 Sep. 2019
Kommentiert: Florian Anderl am 16 Aug. 2023
I have just installed MATLAB 2019b on a Macbook Pro 2019 running macOS Mojave 10.14.6.
Just after installation, Matlab ran fine. However, if I now try to open it I see the splash screen then it freezes on the Matlab window showing no content and I have to force quit. If I run from the command line with -nodesktop it works and I can even load the desktop from there and it works ok. But if I try to load directly it hangs. I doubt it is a conflict as I have installed barely anything else on this macbook yet.
  29 Kommentare
Athar Ali
Athar Ali am 28 Aug. 2022
I experience same issue on MAC book Pro. Matlab 2020b and Matlab 2022a. While editing the figure or scope image.

Melden Sie sich an, um zu kommentieren.

Antworten (23)

Jon Gotow
Jon Gotow am 29 Okt. 2019
Bearbeitet: Jon Gotow am 21 Mär. 2021
I'm the developer of Default Folder X. With the help of Philip Slaymaker I've tracked down the issue with Matlab. Matlab doesn't launch correctly if other apps use the Accessibility API (a part of macOS) to query it for information while it's launching.
A number of apps use the Accessibility API to communicate with other applications. These include Default Folder X, Magnet, Spectacle, and most other utilities that help you arrange / resize windows. If you run into this problem, you can narrow down the possible culprits by going to System Preferences > Security & Privacy > Privacy > Accessibility. This list shows all the applications that you've given permission to use the Accessibility API - one of them is triggering the bug in Matlab and causing it to hang. You'll need to use a process of elimination to determine which one, but it'll usually be an app that gets and sets information about other applications' windows.
Note that contacting the developer of any of these applications won't really help much, as it's not their fault. The fundamental issue is that Matlab contains a bug that causes it to hang when other apps request information via the Accessibility API. That bug needs to be fixed to resolve this problem. Phil Slaymaker submitted the bug to MathWorks - hopefully they'll fix it soon.
In the meantime, if you're a Default Folder X user, I have a version of DFX that may successfully work around the problem. I'd appreciate hearing from you at support (at) stclairsoft (dot) com.
- Jon
  31 Kommentare
Duncan Carlsmith
Duncan Carlsmith am 13 Apr. 2023
Bearbeitet: Duncan Carlsmith am 13 Apr. 2023
I found just now this advice fixed a number of issues, run 2023a MacBookPro M1 Ventura. Disabled Grammarian accessibility access and voila!! Thank you Jon.
P.S. After doing this, another issue disappeared - I found Image Viewer and Color Thresholder apps started working again. They would launch and then after loading a file become unresponsive.

Melden Sie sich an, um zu kommentieren.

CoolNickname am 16 Mär. 2020
Bearbeitet: CoolNickname am 24 Mär. 2020
I had the same problem today with R2019b. Out of nowhere - well, after installing update 5 of R2019b - it stopped working. MATLAB would just not open after clicking it. The little dot under thy icon appeared and disappeared shortly after.
But I was able to start MATLAB through the terminal via
But the real problem solver was to give it full disk access. For that please go to Preferences > Security & Privacy > Privacy > Full Disk Access. There you should check MATLAB. Or, if it isn't listed, click on the + and look for it in the Application folder and add it to the list manually. After doing that it was good to go.
I also use the app "Magnet", but that didn't cause the problem. However, one should constrain Magnet to ignore MATLAB, otherweise MATLAB could be quite laggy.
Hope that helps.
  9 Kommentare
Florian Anderl
Florian Anderl am 16 Aug. 2023
Fixed it for me. Thank you very much.

Melden Sie sich an, um zu kommentieren.

Selene Schmittling
Selene Schmittling am 22 Apr. 2020
Here I am again in this Discussion thread. I was so hoping I wouldn't have to return.
I run MATLAB R2019b on macOS Catalina 10.15.4. I have not had issues with MATLAB in a while then suddenly (when I'm under a time crunch, of course) I get the whiring pinwheel of death every time I open MATLAB.
What I am posting now is a quick and dirty way to get a responsive instance of MATLAB (I can't worry about an actual fix right now).
I open an instance of Terminal. I type "/{path_to_your_matlab_application_folder}/bin -nodesktop" (replace the material in braces {} with the path to your Matlab application folder).
This starts a command line instance of MATLAB (I assume). At the ">>" prompt I type "desktop".
Then I find myself in a working instance of MATLAB able to do my work.
You can find this solution by querying "MATLAB not responding". I may have cobbled it together by reading more than one post. I wanted to share here in the hopes that it kept others from unnecessary hair loss.
  11 Kommentare
Anand Kulkarni
Anand Kulkarni am 31 Mär. 2021
Thank you for posting this!! It works for me. 2020a with 10.14.6.

Melden Sie sich an, um zu kommentieren.

Lin Qi
Lin Qi am 12 Aug. 2020
Here is a solution maybe. Open MATLAB, and then open another app, or let another app come into the front, anyway let the MATLAB starting in the background. Then it would successfully startup every time on my laptop. If I just open MATLAB and let it starting in the front, it would be randomly a success or failure. Can't find any pattern.
  6 Kommentare
Peter Kaczkowski
Peter Kaczkowski am 11 Dez. 2020
Changing focus works for me too with 2019b. Unfortunately, the code I need to run does not yet work with 2020b, so I'm SOL.

Melden Sie sich an, um zu kommentieren.

Zongde Qiu
Zongde Qiu am 19 Sep. 2019
same issue on MacOS 10.14.6

Selene Schmittling
Selene Schmittling am 23 Sep. 2019
I have finally gotten MATLAB 2019b to work on my mac with os 10.14.6.
Initially, I could not even get MATLAB to run in Safe Boot Mode. However, after a clean uninstall (including deleting Mathworks folder out of "Application Support" folder, I was able to get it running.
There were four possible sources of conflict: Goolge Drive Stream, OneDrive, Spectacle and Echo Desktop auto-loader (loads when Echo pen connected to USB).
I turned all these off and opened MATLAB and it worked.
I turned off the automatic load of Echo Desktop and turned it back on. MATLAB still working
I also have a piece of software called Spectacle, which sizes windows with keystrokes. I turned that off and have since turned it back on and am still running MATLAB successfully.
I have not started up Google Drive Stream or OneDrive yet. I'm just so happy to have MATLAB working, I don't want to tempt fate. When I turn these back on, I'll post back my results.
I hope this helps someone else struggling with this issue too.
Regards and good luck,
  5 Kommentare
Selene Schmittling
Selene Schmittling am 3 Nov. 2019
AAAAAARRRRGGGHHHH!!!! This ridiculous bug is back (of course when I need to get some work done). I have this issue on a Mac Book Pro 2016 running Catalina 10.15.1.
MATLAB® people: please, please fix this.
I have been running MATLAB fine, even with Spectacle running, then out of the blue, MATLAB hangs again. Once it hangs, there is no way to get it running without reinstalling the whole mess again shy of (hopefully) booting in safe mode.
I went in and removed all items that required accessibility to whit: Spectacle, Duet and Google File Drive Stream. I have rebooted my machine (multiple times) and MATLAB still hangs.
This is beyond infuriating. I'm going to boot into safe mode and hope I can get my work done.

Melden Sie sich an, um zu kommentieren.

Gregor Dumphart
Gregor Dumphart am 11 Dez. 2020
I was also troubled by Matlab R2020b getting stuck usually in the first minute of use on macOS Big Sur. I followed all suggestions in this topic, but to no avail.
Here's what fixed it for me: In System Preferences -> Accessibility -> Zoom, deactivate everything, especially Advanced -> Smooth Images. Immediately, my Matlab experience became a hundred times more fluent and I am stuck-free ever since.
  1 Kommentar
Guo Jack
Guo Jack am 2 Dez. 2021
Thank you so much. This also works for me.

Melden Sie sich an, um zu kommentieren.

Jason am 1 Dez. 2019
I'm not sure if this is related, but when I upgraded to Catalina, I lost the ability to access many folders on my computer (Matlab R2017b). I added Matlab under System Preferences --> Security & Privacy --> Privacy --> Full Disk Access, but it didn't change anything. Upon bootup, Matlab can't find many of the files in the Matlab path. And I can't navigate to a lot of folders on the disk.
  1 Kommentar
Jason am 1 Dez. 2019
I think I found the reason for the issue. Catalina moves any folders in the root directory of the computer into this folder: /Users/Shared/Relocated Items.
This effected some of my folders, so I will have to update everything in my Matlab path definition file unfortunately.

Melden Sie sich an, um zu kommentieren.

Feiran li
Feiran li am 14 Feb. 2020
Have the same problem Matlab2019b macOs Catalina 10.15.3. solved the problem by blocking Dropbox from System Preferences --> Security & Privacy --> Privacy --> Accessibility.
  3 Kommentare
George A.
George A. am 24 Nov. 2020
Bearbeitet: George A. am 24 Nov. 2020
I had to remove the app Contexts. Dropbox is ok for me.
With Contexts enabled I have to delete the folder "~/Library/Application\ Support/MathWorks/MATLAB/R2019b/" before opening Matlab.

Melden Sie sich an, um zu kommentieren.

Brian Taylor
Brian Taylor am 7 Mär. 2022
I have multiple screens and a laptop, Matlab refuses to go past the spash screen. I have discovered that by unplugging all of the extra screens that it will start. Would be nice to get this bug fixed.

Jonathan Lilly
Jonathan Lilly am 4 Okt. 2019
A perhaps similar issue for me. Matlab 2019b was working, but there was a strange bug which is that I was unable to select text with the mouse in Matlab, which I do all the time. After reading this thread, I traced the problem to a window-sizing software called Magnet that I had recently installed. This solved the problem. Thanks!

Philip Slaymaker
Philip Slaymaker am 26 Okt. 2019
I had a similar issue with Matlab 2019b (Matlab 2019a worked fine) not finishing initializing the command window and then freezing, requiring a force quit of Matlab. This happened on both Mojave 10.14.6 and High Sierra 10.13.6 on the iMac 27 2019 and 2017, respectively. I found that quitting and not running Default Folder 5.4.1 at all (or earlier versions) allowed Matlab to load and run. Rerunning Default Folder while Matlab was running caused Matlab windows to freeze.

Andriy Yabluchanskiy
Andriy Yabluchanskiy am 7 Nov. 2019
Bearbeitet: Andriy Yabluchanskiy am 7 Nov. 2019
i found that the problem, at least on my end, is somehow connected to the network in my institution. matlab runs fine when on my home network but always freezes on splash screen when at work
macOs Catalina 10.15.1
Matlab 2019b

robin tournemenne
robin tournemenne am 23 Jan. 2020
I also have this problem. Among the list of possible conflicts with other softwares I see spectacle that I use basically always. Very annoying, please do something mathworks, now I need to work in the terminal witht he command matlab -nodesktop...

Selene Schmittling
Selene Schmittling am 23 Jan. 2020
So, for the last few months, I have basically resorted to unloading Spectacle whenever I use MATLAB and not loading it again until I've close MATLAB.
This is extremely annoying but certainly less annoying than the unending spinning pinwheel of death.
Since using this procedure, I have not encountered any freezing issues. I have not checked whether OneDrive or Google File Stream continue to be issues. I will try to remember to do that and report back.

Yiqian Qian
Yiqian Qian am 24 Feb. 2020
For my case, it conflicts with Google Drive Backup & when i quit Google Drive, it can be launched succesfully.

Mickey London
Mickey London am 28 Apr. 2020
The feedback of disabling accessibility applications worked for me. The App the caused the issue was Magnets.
When checked out, Matlab stopped hanging.

Sangjae am 29 Jun. 2020
Bearbeitet: Sangjae am 29 Jun. 2020
I have same problem, MATLAB 2020a & MacOS Catalina
  2 Kommentare
Sangjae am 30 Jun. 2020
Thanks!, I tried removing all items checked in the accessibility,
but, unfortunately, it doesn't work in my case.
when I checked the syslog (/var/log/system), it said[1] (com.mathworks.matlab.19992[1601]): Service exited with abnormal code: 1

Melden Sie sich an, um zu kommentieren.

Stefan Baginski
Stefan Baginski am 15 Aug. 2020
My solution to this and the only one which allowed me to start MATLAB again was to delete the ~/Library/Application Support/MathWorks/MATLAB/R2020a
Afterwards MATLAB started again but unfortunately your settings are gone. So I recommend to make a copy of the folder just in case. But so far I was not able to figure out which file is causing the issue.
  3 Kommentare
Dave am 4 Sep. 2020
Yes, this was mentioned above, and it works for me. Easy but not very satisfying.

Melden Sie sich an, um zu kommentieren.

Toby Driscoll
Toby Driscoll am 2 Sep. 2020
For me the key was adding MATLAB to System Prefs / Security & Privacy / Accessibility. I'm running DFX, Dropbox, Google Drive Stream, and Spectacle–did not have to change those.
(This is for release 2020a on Catalina.)
  2 Kommentare
Dave am 4 Sep. 2020
Yes, this did not work for me either.

Melden Sie sich an, um zu kommentieren.

Griffin Willis
Griffin Willis am 7 Sep. 2020
This has been happening to me too, I've figured out a way around it by simply going into your documents and opening a matlab file from your folders to launch matlab that way.
  1 Kommentar
Jon Sporring
Jon Sporring am 13 Okt. 2020
I just had this problem with R2020b (9.9.01467703) on macOS Catalina (10.15.7). It was solved by starting /Applications/ from a terminal (with full disk access) once. Now Matlab does not hang, when I start it from Finder. Good luck.

Melden Sie sich an, um zu kommentieren.

Brett Tofel
Brett Tofel am 25 Okt. 2020
Same on bug on 2020a for Mac Catalina as with 2020b above, and same fix, but I remember this dumb bug from like 2018? This should really get fixed!

Guo Jack
Guo Jack am 6 Dez. 2020
Bearbeitet: Guo Jack am 6 Dez. 2020
I tried above advices but it's still not working. I found another solution from
This is what I did:
1) Open terminal and type (you need to change the version in the following command line)
/Applications/ -nodesktop
2) Type “desktop” when matlab starts
3) Go to desktop matlab preference. Under "general", change the initial working folder to another one and it workded for me.
I benefit a lot seeking solutions for matlab issues and want to thank you all in this forum.
Hope it helps for y'all.


Mehr zu Startup and Shutdown finden Sie in Help Center und File Exchange





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by