Error using syms x: mupadmex,s​ym>cell2re​f,sym>tomu​pad

9 Ansichten (letzte 30 Tage)
Jordan Dion
Jordan Dion am 23 Jul. 2018
I used 2018 matlab on my macOS and at some point syms x does not work, it produces errors. I add that this issue persists on my windows 10 pc. I have tried reinstalling, and downgraded to 2017 (currently)
The error produces:
>> syms x
Error using mupadmex
Error in MuPAD command:
Error in sym>cell2ref (line 1308)
S = mupadmex(y);
Error in sym>tomupad (line 1246)
S = cell2ref(numeric2cellstr(x));
Error in sym (line 199)
S.s = tomupad(x);
Error in syms (line 192)
toDefine = sym(zeros(1, 0));
MATLAB Version: (R2017a)
MATLAB License Number: STUDENT
Operating System: Mac OS X Version: 10.11.6 Build: 15G22010
Java Version: Java 1.7.0_75-b13 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode
MATLAB Version 9.2 (R2017a)
Simulink Version 8.9 (R2017a)
Control System Toolbox Version 10.2 (R2017a)
DSP System Toolbox Version 9.4 (R2017a)
Image Processing Toolbox Version 10.0 (R2017a)
Instrument Control Toolbox Version 3.11 (R2017a)
Optimization Toolbox Version 7.6 (R2017a)
Signal Processing Toolbox Version 7.4 (R2017a)
Simulink Control Design Version 4.5 (R2017a)
Statistics and Machine Learning Toolbox Version 11.1 (R2017a)
Symbolic Math Toolbox Version 7.2 (R2017a)
  11 Kommentare
Jordan Dion
Jordan Dion am 21 Sep. 2018
My PC is using r2017b and it is working.

Melden Sie sich an, um zu kommentieren.

Antworten (3)

Yiqian Qian
Yiqian Qian am 16 Aug. 2019
Same problem for MATLAB r2019a on my MBP
  3 Kommentare
Walter Roberson
Walter Roberson am 9 Mai 2020
It appears that there are problems using Mojave or Catalina until one of the R2019b updates.

Melden Sie sich an, um zu kommentieren.

Matthew Love
Matthew Love am 6 Okt. 2019
Also having this issue
Currently on OS 10.14.6 "Mojave"
Originally booted up Matlab 2017 (cannot remember a or b) and tried to use 'syms' command. Gave me the "mupadex" error. First time I've ever seen that. No issues last time I used it.
Could not find way around it, so I deleted Matlab entirely and upgraded to 2019b, and the issue persists unchanged.

r_avelino am 11 Feb. 2020
Same problem here. Can not use syms function.
I am using Matlab2019b in MacOS Catalina 10.15.2
This is what I get in my Matlab Terminal when I try to create the symbolic varible:
>> syms x;
Error using mupadmex
Error in MuPAD command: .
Error in sym>tomupad (line 1250)
S = mupadmex(numeric2cellstr(x));
Error in sym (line 217)
S.s = tomupad(x);
Error in syms (line 232)
defined = sym(zeros(1, length(args)));
It was working properly before but I can not precise when it stoped to work. If I type the command suggested above I get the corresponding adress for the mupadmex.mexmaci64 file.
which -all mupadmex
  2 Kommentare
r_avelino am 11 Feb. 2020
Thanks for the answer Walter. Indeed I updated to Matlab 2019b and the problem with the symbolic variables is fixed

Melden Sie sich an, um zu kommentieren.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by