MATLAB Answers

Error while obtaining sizes from MEX S-function 'arduinodi​gitaloutpu​t_sfcn' in 'arduino_g​ettingstar​ted/Digita​l Output/Digital Output'.

6 views (last 30 days)
Asha Dharan
Asha Dharan on 30 May 2018
Commented: Jayson Peters on 7 Mar 2020
How can I fix the following error(ref screenshot) . I am using Matlab R2018a, Simulink Support Package for Arduino Hardware version

Answers (1)

Pradeep KS
Pradeep KS on 4 Jun 2018
In 18a, the Simulink Arduino support package is not using "arduinodigitaloutput_sfcn" mex file. I think there are files from older versions which are on the MATLAB path. Could you please run the below command and check from where the "arduinodigitaloutput_sfcn" mex file is getting loaded.
>> which arduinodigitaloutput_sfcn
Please post the output of the above command for further help.


Show 2 older comments
Daniel Chizhik
Daniel Chizhik on 23 Jul 2018
I am also having this problem with running the Arduino packages on 18a. I tried the first suggestion and I'm getting the same result as Asha. I also checked the outputs of >>which-all arduino_gettingstarted and there was only one.
Dinesh Sequeira
Dinesh Sequeira on 31 Jul 2018
I get a similar error when using TI "MSP430G2553_gettingstarted" with "Embedded Coder Support Package for Energia" and using MATLAB R2018a In touch with support but no solution so far. Case #03179769 ref:_00Di0Ha1u._5000Z12cHx1:ref

Sign in to comment.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by