Filter löschen
Filter löschen

SIMULINK ROS Permission denied

23 Ansichten (letzte 30 Tage)
Albin Biju
Albin Biju am 27 Nov. 2021
Caused by: Permission denied
  3 Kommentare
Mahshad Kadkhodazade
Mahshad Kadkhodazade am 5 Dez. 2022
I'm having the same error. I attached my model.
p.s.: first time, I initialized roscore on ubuntu, then on matlab. I got this error.
second time, I restarted my computer and this time initialized ros on matlab. Still the same error.
Mahshad Kadkhodazade
Mahshad Kadkhodazade am 5 Dez. 2022
I solved it by going to matlab script and changing the folder directory to the folder where the python code of my publisher node exists. I got this idea from below link:
https://forums.ni.com/t5/LabVIEW/permission-denied-error-when-using-Matlab-script/td-p/3209865
p.s.: I got this error in Simulink of a ROS publisher block. I had defined a publisher node in ROS before running this simulink block.

Melden Sie sich an, um zu kommentieren.

Antworten (1)

Jagadeesh Konakalla
Jagadeesh Konakalla am 7 Apr. 2023
Based on the error message, you are running the model where you do not have write permissions. Please run the simulink model where you have write permissions.
Thanks,
Jagadeesh K

Kategorien

Mehr zu Introduction to Installation and Licensing finden Sie in Help Center und File Exchange

Produkte


Version

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by