Filter löschen
Filter löschen

CMake not found when using rosgenmsg on Windows

8 Ansichten (letzte 30 Tage)
Albert Thelemann
Albert Thelemann am 6 Nov. 2021
I ran into the similar problems desribed here with the difference of me having Matlab 2021b which is installed on Windows 10. I, too, use Ros1 (Noetic, running over WSL) and tried to run rosgenmsg with the path to the messages which results in the following error:
Error using ros.internal.utilities.getCMakeBinaryPath (line 24)
Could not find CMake in your system. Please install CMake version 3.15.5 or higher and rerun the command.
I tried several different things:
  • Different versions of Cmake (3.15.5, 3.22), I added them to path while installing, added them to path via Matlab.
  • A different PC with same versions of software, but a more up to date windows version, same Problem.
  • Different Installation folders (C:/..., C/Programms/..., D/... and so on) With blank spaces in the path and without etc.
  • Most of the solutions in the post linked above sadly dont apply to my version of the problem and the others didnt work for me.
The following command (in Matlab) give the following results back:
  • "!cmake --version" gives me:
"cmake version 3.15.5
CMake suite maintained and supported by Kitware (kitware.com/cmake)."
In a windows terminal "cmake --version gives the same result as above, so verything seems to be normal
  9 Kommentare
Stefan Kubica
Stefan Kubica am 6 Mär. 2022
Bearbeitet: Stefan Kubica am 6 Mär. 2022
Good Morning,
I have the same problem on a Windows 10 machine and Matlab 2021b. I also tried different versions of CMake but no difference. Perhaps, there was a solution on this issue? I already gave a message to the Matlab Support but wanted to give it a try here.
Thanks and best wishes
Stefan
Albert Thelemann
Albert Thelemann am 7 Mär. 2022
Hi Stefan,
which problem exactly? Because as far as I can remember there were 2 parts to the solution. The more important part was to copy the custom msg folder onto windows (somewhere, doesnt really matter where exactly) and then run the command. Beforehand I tried to do it with the path to the WSL system which didn't work. This still requires a working visual studio compiler though, so you have to make that work as well. For me, visual studio 2017 worked.
Kind regards,
Albert

Melden Sie sich an, um zu kommentieren.

Antworten (1)

Jagadeesh Konakalla
Jagadeesh Konakalla am 12 Apr. 2023
The fix for this issue is addressed in the update release of R2021b. Please use the latest update release of R2021b

Kategorien

Mehr zu Specialized Messages finden Sie in Help Center und File Exchange

Tags

Produkte


Version

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by