Filter löschen
Filter löschen

Minus vanishes with Latex interpreter (Linux system)

4 Ansichten (letzte 30 Tage)
Jannick
Jannick am 27 Mär. 2012
When using latex interpreter for text(...) the minus sign vanishes in superscript and in \frac{}. I tried linking my latex base folder to matlab but this has not solved the problem.
  4 Kommentare
Wayne King
Wayne King am 25 Apr. 2012
I don't have this problem with Debian 6 running R2012a
Walter Roberson
Walter Roberson am 26 Apr. 2012
Remember the Linux font problems of R2010a-ish. Some of those were tracked down to some versions of Linux not installing all the necessary fonts; and some of the problems were tracked to the default X library having improper optimizations; and some of the problems I did not hear the cause of.

Melden Sie sich an, um zu kommentieren.

Antworten (2)

Daniel Shub
Daniel Shub am 26 Apr. 2012
This seems too long for a comment, but it is not really an answer either ...
I am pretty sure MATLAB uses its own LaTeX engine and does not generally make use of any installed versions of LaTeX (similar to how MATLAB deals with JAVA).
If I recall the days before export_fig when I was using Windows, exporting figures to .ai/eps/pdf files and importing them to Illustrator used to cause the minus sign to disappear.
What renderer are you using?
Can you post example code so we can try and reproduce the problem?

Jannick
Jannick am 7 Mai 2012
I am running R2008a. I use ubuntu 10.04 and haven't changed any library there, so i don't really know which library I am using.
A running example is:
x=0:10;
y=0.5*x;
plot(x,y);
text(1,4,'$\exp{-x^2}$ or $x^{-2}$','interpreter','latex');
print -depsc test.eps
In the matlab figure the minus vanishes, whereas in the eps the x^2 and 2 are printed on the minus. The minus takes somehow no space.

Kategorien

Mehr zu Introduction to Installation and Licensing finden Sie in Help Center und File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by