MATLAB Answers

Updating image for Beaglebone Black leads to "No connection" error

2 views (last 30 days)
Carlos gonzalez
Carlos gonzalez on 17 Nov 2016
Commented: Manish M on 27 Jun 2019
This is something that faced yesterday, BBB Rev C with image from fabric, was connected to Simulink and worked fine, after updated with a version from angstrom (2013.09.04), Simulink was not able to connect again with the Beaglebone Black, looking in the support from mathworks the recomendation was close if any session still open, but there were not connection opened, checked by the command "bbb = beaglebone" which throws the following errors:
Error using beaglebone/updateServer (line 1169) Error executing command: sh: sudo: command not found
Error in beaglebone/launchServer (line 1194) updateServer(obj);
Error in beaglebone (line 254) obj.launchServer;
Tried to removed the "sudo" command for the lines but didn't work. So a another image for be flashed into the BBB (bone-debian-8.6-lxqt-4gb-armhf-2016-11-06-4gb.img), after have the new image simulink could connect to the board again.
I hope this experience works if you're facing the same problem. And someone with more knowledge could explain the real problem.

Answers (0)

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by