"doc cmp": Help browser stuck at "Processing"

2 views (last 30 days)
FM on 18 May 2022
Edited: FM on 24 May 2022
My organization just upgraded me to Matlab 2022a. "doc table" works, but "doc cmp" causes the help browser to be stuck at the message "Processing". It does not become unstuck if I type "table" into the search field. I can still issue "doc table" at the command window, which opens a 2nd help browser tab with the "table" help page. I can switch to the "Processing" tab and close it. So the "Processing" tab doesn't impede any other use of "doc". But I was hoping to be able to use the help browser instead of the internet to look for Matlab commands (such as "cmp") so that I don't end up using a reserved word for a variable. Is there a particular reason why "doc cmp" brings up a zombie help browser tab?
Les Beckham
Les Beckham on 19 May 2022
You're welcome. I'm happy to be of assistance.

Sign in to comment.

Accepted Answer

FM on 24 May 2022
Edited: FM on 24 May 2022
The MathWorks suggested a fix that worked for me. The solution was to delete temporary files: Type in %Temp% in the Windows explorer and it should take you to
C:\Users\<your username>\AppData\Local\Temp
Take a backup of this directory and then delete all the files here. After that restart MATLAB and see if the issue persists.
If the above had not worked, the next step would have been to re-install Matlab, which was thankfully unnecessary.

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by