Transform sensor - problem with position

2 views (last 30 days)
Lindrit Hasani
Lindrit Hasani on 14 Apr 2022
Answered: Steve Miller on 19 Nov 2022 at 17:46
Hey,
i have a problem with the transform sensor block. I'm trying to visualize a laser between two bodies in simulink. One of the bodies is constantly moving. Thats why i've tried with 2 transform sensor, which are attached to my world frame and to one of my bodies, to get a linear equation. This linear equation is the input for a joint which is attached to the not moveable body. In my mind, simulink should now visualize a laser between this two bodies and the laser should look like as if is it attached to both of the bodies.
This works, but the problem is that there are some areas of points, where the laser is not doing what it should do and there are some other areas where it works perfectly fine.
Can someone explain me, why?

Answers (1)

Steve Miller
Steve Miller on 19 Nov 2022 at 17:46
Without seeing your model, it is hard to know the exact reason.
These are common issues for models of this type:
  1. Your Measurement Reference frames are inconsistent.
  2. Your joint is expecting "extrinsic" angles, but you are applying "intrinsic" angles... or vice-versa.
Share your model and we might be able to help further.
--Steve

Categories

Find more on Simscape Multibody in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by