This is machine translation

Translated by Microsoft
Mouseover text to see original. Click the button below to return to the English version of the page.

Note: This page has been translated by MathWorks. Click here to see
To view all translated materials including this page, select Country from the country navigator on the bottom of this page.

Compare Revisions

To review changes in modified files in Simulink® Project, select the Modified (number of files) tab.

If you need to update the modified files list, click Refresh in the source control section of the Simulink Project tab.

To review changes in modified files, right-click selected files in any view in Simulink Project and:

  • Select Compare > Compare to Ancestor to run a comparison with the last checked-out version in the sandbox (SVN) or against the local repository (Git™). The Comparison Tool displays a report.

  • To compare other revisions of a file, select Compare > Compare to Revision. In the Compare to Revisions dialog box, you can view information about who previously committed the file, when they committed it, and the log messages. To view a comparison report, select the revisions you want to compare. You can:

    • Select a revision and click Compare to Local.

    • Select two revisions and click Compare Selected.

    • With SVN, select a revision and you can browse the lower list of files in the change set. Right-click a file in the list to view changes or save revisions..

  • To browse the revision history of a file, select Source Control > Show Revisions. In the File Revisions dialog box, view information about who previously committed the file, when they committed it, and the log messages. With SVN, select a revision and you can browse the lower list of files in the change set. Right-click a file in the list to view changes or save revisions.

  • To browse and compare files within committed SVN change sets, on the Simulink Project tab, in the Source Control section, select Show Log. In the File Revisions dialog box, select a revision to view a list of modified files. Right-click files in the lower list to view changes or save revisions.

Note

In the Simulink Editor, if an open model, library, or chart belongs to a project under source control, you can view changes by selecting File > Simulink Project > Compare to Ancestor or Compare to Revision.

When you compare to a revision or ancestor, the MATLAB® Comparison Tool opens a report comparing the modified version of the file in your sandbox with the selected revision or against its ancestor stored in the version control tool.

Comparison type depends on the file you select. If you select a Simulink model, this command runs a Simulink model comparison.

When reviewing changes, you can merge Simulink models from the Comparison Tool report. See Merge Text Files and Merge Models.

To examine the dependencies of modified files, see Perform Impact Analysis.

Related Examples

More About