MATLAB Answers

rwtbuild using parallel computing toolbox aborts because no project is currently loaded

1 view (last 30 days)
Didier Billard
Didier Billard on 21 Jan 2020
Edited: Didier Billard on 21 Jan 2020
Hello,
I am currently trying to generate code using rtwbuild coupled with Parallel Computing Toolbox.
Hereunder is described the procedure I used trying to generate code in parallel:
First I begin with setting configuration parameter "EnableParallelModelReferenceBuilds" to all of my models.
Then I execute parpool() command and MATLAB told me it was OK.
Then I run rtwbuild on my top model using "OpenBuildStatusAutomatically" to see what is happening:
this command starts to display encouraging messages such as "Parallel workers initialization completed" and several "Starting parallel model reference RTW..."
Allas this was just a fake as the generation aborts suddenly with the following error message:
Error using simulinkproject
No project is currently loaded
I tried again checking that simulinkproject is effectively loaded using isLoaded command just before executing rtwbuild command: this new trial failed although isLoaded has proved that simulinkproject was loaded.
Does anyone know what is wrong in my procedure ?
Thank you in advance for yourhelp.
Best regards.

  0 Comments

Sign in to comment.

Answers (0)

Sign in to answer this question.


Translated by