MATLAB Answers

1

Why Don't Set Breakpoints Work in R2018b?

Asked by Dirk Bell on 6 Feb 2019
Latest activity Commented on by Dirk Bell on 11 Feb 2019
I set breakponts in the script and they are ignored. The script executes past them. The breakpoints remain set (bright red). I have restarted MATLAB. I have restarted my computer then restarted MATLAB. I have cleared and reset the the breakpoints manually. I tried using the menu breakpoint Clear All and then manually resetting them. No change. I do not 'clear' anything in the script but my own variables. The code is definitely executing right past the breakpoint.
I tried resetting the breakpoints after a save right before executing the script (recommended here for another version). Nope. I read here about similar problems in other versions (like did you 'clear java') - not related to my problem.

  5 Comments

Is the break point line un-reachable? How about setting the break point on the first line and then step?
Rik
on 6 Feb 2019
What I meant is if you were using the 'run section' option (either from the lint, or by using ctrl+enter). In my experience that does sometimes cause issues with breakpoints.
Also, your answer is not an answer. You should delete it and repost it as a comment. Now other contributors might think your issue has been solved, since there is an answer.
All breakpoints are on lines that are never conditionally executed.
As you suggested I put a breakpoint on the first command in the file. Didnt stop. I put a string right after the breakpointed first command. The string is displayed.
I have also verified I am setting all of the breakpoints in the files I am executing using the 'which' command.
Not using the "run section" option.

Sign in to comment.

1 Answer

Answer by Yair Altman on 11 Feb 2019

This could happen if your script runs inside a parallel loop (spmd or parfor), or is shaddowed by a binary version (e.g., file.m shaddowed by file.p or file.mex).
In such cases, Matlab uses a compiled version of the code and does use the source code in your script file, therefore never stopping at your breakpoint.

  1 Comment

None of these is the case.
A full power down and restart fixes it for a while.

Sign in to comment.