Clueless why I get the error "unable to find a register to spill in class 'POINTER_REGS' " for my model in simulink?

2 views (last 30 days)
I have made my own model in simulink to control my arduino. If I start the model for one PWM- and Analog-Pin I Don't get any error at all. But if I start my Model for more then obe PWM- and Analog-Pin I get the requested error.
And I don't think the problem is about my compiler, because if it was about the compiler the error should appear even for one Pin and not for two or several more or am I wrong?
I think the problem is about the Timings, but I'm not sure and if yes I don't know how to solve it by now...
Does somebody have the same problem and have solved it?
thank you for your help :)

Accepted Answer

Tobias Wzl
Tobias Wzl on 29 Jan 2018
solved it, i had to change the solver settings for my code generation; i had to switch from automatic to ode8 :)

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by