MATLAB Answers

0

!explorer No Permision

Asked by Yuval Weissler on 20 Mar 2016
Latest activity Commented on by Yuval Weissler on 24 Mar 2016
I've uploaded an image to do the talking for me :)
How can I solve this?
EDIT: It might be helpful to point out that my problem has start with winopen not opening folders, and after some googling I've arrived at this error message I've posted.
Also, I've already tried to play all kinds of permissions, and nothing worked so far.
Lastly, this problem started after I've replaced my computer with a laptop. Both run Windows 7, both are 64 bit, and both run the same Matlab version (2013a), but for some reason, the laptop gives this error (and in case anyone is wondering, my code is 100% 'correct', because it worked on the PC (and other PCs for that matter) and has not changed ever since).

  0 Comments

Sign in to comment.

Products

2 Answers

Answer by Image Analyst
on 20 Mar 2016

It worked for me (R2015b and Windows 10).
Perhaps you want to call winopen to the folder you want:
folder = 'C:\whatever';
winopen(folder);
Does that work?

  2 Comments

Nope. Actually, my problem start with winopen not opening folders, and I've arrived at this error message I've posted.
If you run explorer from a command console window, or an icon, what folder does it open up to?

Sign in to comment.


Answer by Jan
on 20 Mar 2016

It seems like the startup folder of the Explorer contains an invalid path. Try to set the path manually:
!c:\windows\explorer.exe /n,/e,c:\
Does this work?
Then check the default folder:
Perform a shift-right-click on the explorer icon in the task bar. Open the "Properties" tab and adjust the "Target", e.g. to "%windir%\explorer.exe /e,D:\". See also: http://www.howtogeek.com/howto/17415/set-the-windows-explorer-startup-folder-in-windows-7
Note that this is a problem of the operating system, not of Matlab. Therefore it is off-topic in this forum.

  7 Comments

Jan, when trying: !c:\windows\explorer.exe /n,/e,c:\ -- literally nothing happens.
When trying c:\windows\explorer.exe /n,/e,c:\ in the cmd terminal, explorer open the C:\ directory.
It worked for me, sooooooooooooooooo we're back to calling tech support, like I suggested. What happened when you called them today? Did they help you?
I know it works on other computers, and I know it's probably a 'windows problem', but I can't find a way to fix it, and in the meantime it's only affecting my Matlab working capabilities.
I was hoping that someone around here had encountered this problem before, that's all :)
Tech support didn't respond for some time now (and yes, I have a confirmation mail that my question was filed successfully).

Sign in to comment.