Run Dependency Analysis

Note

You can analyze only files that are in your project. If your project is new, add files to the project before running a dependency analysis. See Add Files to the Project.

  1. In the project Views pane, select Dependency Analysis.

  2. If you want to analyze the dependencies of external toolboxes, select Options > Analyze External Toolboxes.

    After you run the first dependency analysis of your project, subsequent analyses are incremental updates. However, if you update external toolboxes and want to discover dependency changes in them, you must perform a complete analysis. In this case, turn off Options > Perform Incremental Updates before running the dependency analysis.

  3. To analyze all files in your project, on the Dependency Analysis tab or view, select Analyze.

    If you want to analyze specific files, on the Dependency Analysis tab, click Analyze > Select Files to Analyze. In the Dependency Analysis dialog box, select files for analysis, and click Analyze.

Note

In the Simulink® Editor, if an open model, library, or chart belongs to a project, you can find file dependencies. On the Simulation tab, select Project > Run Dependency Analysis. Simulink analyzes the whole project and shows upstream and downstream dependencies for the file.

For next steps, see:

Tip

To try a dependency analysis on example files, see Perform Impact Analysis with a Project.

Related Topics