MATLAB Answers


Matlab Compiler

Asked by Fabrizio Schiano on 28 Oct 2011
Latest activity Answered by Sorath Asnani on 16 Sep 2014

Hi I want to include in a Simulink model a block called "Matlab Function" in which I wrote a simple function with the m-file editor. When I try to run my model I have this error:

"Unable to locate a C-compiler required by Stateflow and MATLAB Function blocks. Use 'mex -setup' to select a supported C-compiler."

How can I do? I'm trying to download a compiler as Windows SDK 7.1, but the download is very very slow. Have you got some links to other compilers?

Thank you in advance!


6 Answers

Answer by Fabrizio Schiano on 28 Oct 2011

I have Win7 64bit and matlab 2011a.

What can i download ? Visual studio and sdk Are too slow to Download. Is there some other alternative software? Thank you!

  1 Comment

The 64 bit compilers supported for your version are listed at

Anything that is not in that table is not supported.

Answer by Fangjun Jiang
on 28 Oct 2011

Try to run "mex -setup" anyway. I thought if you don't have any C compiler, the default lcc will be used. That should be enough if you just want to use MATLAB Function block in a Simulink model for simulation.

  1 Comment

Hi Fangjun,
normally: yes. But Fabrizio has a 64Bit MATLAB that comes not with lcc (since lcc is only supported on 32bit).


Answer by Fabrizio Schiano on 28 Oct 2011

So. What Can I do? I read about the answer of Derek O'Connor, but He said always to download sdk and visual studio c++ and I can't do it!

Please give me a solution :(

  1 Comment

Then install the 32 bit version of MATLAB as well, and start up matlab with the -win32 flag so that you are running the 32 bit version and so would be able to use lcc.

Or get the 64 compiler software shipped to you (or buy it in a store.)

Answer by Egor
on 21 Sep 2012

I also have the same problem but i installed the Microsoft SDK and I have visual studio 2010 installed.


How did you resolve this issue?

VS2010 is not supported for all releases. We would need a more detailed description of the problem (including a copy of what happened with mex -setup) and to know which software releases were involved.

Answer by ehsan
on 12 Jul 2014

I receive the very same message. I installed microsoft VS 2013 and 2012. with 2012 I succeeded to configure mex -setup and MATLAB showed 'successfully recognized' message; still I can use MATLAB function block in SIMULINK because I receive that cursed error message!! please help it's pretty urgent my project is nearly due.


Answer by Sorath Asnani on 16 Sep 2014

Hi.. m too getting the same error message. I am using windows 8.1, Matlab R2013a 64-bit. I have installed sdk and i have visual studio 2013 installed in my PC. but whenever i run mex -setup, i am getting the same message always.. Please help me to resolve this issue.

mex -setup Welcome to mex -setup. This utility will help you set up a default compiler. For a list of supported compilers, see

Please choose your compiler for building MEX-files:

Would you like mex to locate installed compilers [y]/n? y

No supported SDK or compiler was found on this computer. For a list of supported compilers, see

Error using mex (line 206) Unable to complete successfully.


Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

MATLAB Academy

New to MATLAB?

Learn MATLAB today!